Can't enable risi GNOME extension

I disabled this extension, but it’s greyed out. Can’t enable it anymore. Someone with suggestions?

If you disabled it without using risiTweaks, than use that same tool to re-enable it. If that doesn’t work, you’ll need to install dconf-editor (similar to Windows regedit for Linux), head over to /org/gnome/shell/enabled-extensions and add '' to the list (it should be inside the [] and have a comma between each item similar to a python list).

I’ll also try to add a feature to risiTweaks that only greys it out if it’s enabled (since it’s not supposed to be disabled), but allows you to re-enable it if you for some reason disabled it.

Hi again. I disabled it using risiTweaks. I used dconf, and now it says it is enabled and cant’t disable it, but it seems not working. Can’t change Accent Colors and Background Logo doesn’t work either. All other extension works well.

huh weird, risiTweaks shouldn’t let you disable risiGNOME. If you dropdown the menu does it show an error code? If not can you try running journalctl -f -o cat /usr/bin/gnome-shell and pasting any risiGNOME related errors?

Seems to work now! When I used Extension Manager, I saw risiGNOME was disabled, and enabled it. Colors also working!

1 Like

Great! I’ll implement that fix into risiTweaks anyway to prevent further issues in the future.

Thanks for helping out!

1 Like